Home > Call Guide > Frequent pop-up issues for permission requests when connecting a mobile device to a TV
Frequent pop-up issues for permission requests when connecting a mobile device to a TV
No title

Symptom

When connecting a mobile device to a TV, pop-ups for permission appear frequently on the TV.

Examples:

  • When running the TV plug-in on Mobile SmartThings (when selecting a TV device card).
  • When Mirroring your Mobile Device to a TV Using Smart View.

 

Cause

The security policy applied in Android 10 OS or iOS 14 sets the MAC address of mobile devices to  Randomized MAC or Private Wi-Fi Address by default, so the Mac address changes frequently depending on conditions. Each Wi-Fi network uses a different MAC address. (Even with the same Wi-Fi, the MAC address varies depending on 5G or 2.4G)

  • TVs display a permission request pop-up whenever a new MAC address mobile device accesses it.

 

Solution

If you are experiencing inconvenience due to frequent pop-ups for connection permission, you can solve this problem by changing the MAC address setting of your mobile device as below.

  • Android : MAC address type > 'Phone MAC' , iOS : Private Wi-Fi Address 'off

 

* Y24 TVs will be improved by connecting based on Device IDs to prevent frequent pop-ups.

  • TV : 1st  RC (5/14)
  • Mobile version : SmartThings 1.8.13.22 or greater (AOS), 1.7.13.17 or greater (iOS) / Plugin ver 4.GR01.0313 or greater

 

[ How to Change MAC Address Type_Android ]

 

[ How to turn on/off Private Wi-Fi Address _iOS ]

 

 
Was this article helpful?
 Yes  Somewhat  No
If none of the articles addressed your problem, please take a few minutes to describe the problem below.